>> Screenshot erstellen auf Smartphones und PCs

Rechtschreibung: Fehler beim Wort "heiß / heiss"

Komponentenübergreifende Themen zu Libreoffice
Antworten
bergler
Beiträge: 6
Registriert: Mi 27. Apr 2016, 10:17

Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von bergler » Mi 27. Apr 2016, 10:57

LibreOffice Version 5.0.4.2
Gebietsschema: de-CH (de_CH:utf8)
openSUSE 42.1 Leap

Wenn ich in Writer oder Calc das Wort "heiss" eingebe, wird es, unabhängig davon, ob die automatische Rechtschreibeprüfung (Umschalt+F7) eingeschaltet ist oder nicht(!), immer auf "heiß" geändert. Das ist in der Schweiz falsch, hier wird das Doppel-S (lange S, Scharfe S), nie verwendet, d.h. es ist falsch. Meine Spracheinstellungen sind im Uebrigen korrekt (deutsch Schweiz, alles i.O.). Tatsächlich wird das Wort "heiß" auch bei manueller Rechtschreibekorrektur (F7) korrekt als nicht im Wörterbuch enthalten (rot markiert) dargestellt, mit dem richtigen Korrekturvorschlag "heiss", der dann auf Wunsch auch ausgeführt wird.

Nun das Merkwürdigste: Diese Falschkorrektur gibt es nur beim Wort "heiss", nicht aber bei den Wörtern "weiss, Spross, Hass, gross, Steiss, Nuss, Geiss, Scheisse, Fass, dass, lass, nass, Heiss (grossgeschrieben!), Kreisssaal, Kreissaal, heisst, heisse". D.h. "heiss" scheint eine absolute Ausnahme zu sein.

Wahrscheinlich ein Bug! Aber wo? Wo melden?

Vielen Dank für jede Antwort!



bergler
Beiträge: 6
Registriert: Mi 27. Apr 2016, 10:17

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von bergler » Mi 27. Apr 2016, 12:01

Hallo nikki

Die aktive Ersetzungstabelle war Deutsch (Schweiz). Da ist "heiß / heiss" im Gegensatz zu den andern Ländervarianten nicht verzeichnet. Mittlerweile habe ich die Ersetzungstabellen Deutsch (Deutsch), (Liechtenstein), (Luxemburg) und (Oesterreich) geändert, d.h. ich habe die Ersetzung von "heiss" durch "heiß" in allen Sprachvarianten gelöscht und sogar einen Versuch in der Ersetzungstabelle (Schweiz) gemacht, indem ich Ersetzung von "heiß" durch "heiss" eingetragen habe - kein Effekt, "heiss" wird immer noch sofort nach dem Leerzeichen oder der Absatzmarke durch das in der Schweiz falsche "heiß" ersetzt.

bergler
Beiträge: 6
Registriert: Mi 27. Apr 2016, 10:17

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von bergler » Mi 27. Apr 2016, 16:16

Hallo nikki

Ja, das ist das einzige, das bei diesem Wort hilft: die ganze Ersetzungstabelle - in deren bei mir aktiven Variante Deutsch (Schweiz) das Wort gar nicht enthalten ist (!) - deaktivieren.

Herzlichen Dank, dass du dem Problem nachgegangen bist und den Fehler reproduziert hast! Scheint also ein Bug zu sein? Irgend eine Wörterbuchkonfusion? Ich kann mir allerdings nicht vorstellen, dass z.B. ein Englisch-Thesaurus dieses Wort "heiß" mit dem scharfen S / Eszett enthält, und ich kann mir v.a. nicht erklären, weshalb das Löschen des Wortes in allen deutschen Ersetzungstabellen keine Wirkung hat und weshalb offenbar dieses Wort als einziges betroffen ist. Sehr rätselhaft.

Ich möchte einen Bugreport machen. Wo kann ich den posten - kannst du mir da helfen?

Beste Grüsse
bergler

swolf
Beiträge: 1108
Registriert: Di 14. Feb 2012, 16:56

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von swolf » Mi 27. Apr 2016, 19:03

Hallo bergler

bevor du den Fehler meldest, ist es sinnvoll im BugZilla zu schauen,
ob es einen Bugreport dazu schon gibt und ggf. deinen Kommentar dazu fügen.

Eine einfachere Möglichkeit ist, zuerst an die Mailingliste des Projektes zu schreiben.
Das bietet LO-Projekt in den "Versionshinweisen" explizit an
https://de.libreoffice.org/download/release-notes/
Das älteste und meist besuchte Forum für OpenOffice UND LibreOffice
http://de.openoffice.info
ohne: Adsense, Werbung, Spam o.ä.

bergler
Beiträge: 6
Registriert: Mi 27. Apr 2016, 10:17

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss" - Problem teilweise gelöst

Beitrag von bergler » Di 10. Mai 2016, 21:32

Hallo swolf

Das Problem ist teilweise gelöst - man kann das unerwünschte Ersetzungspaar nicht löschen, denn die "Löschen"-Taste hat mindestens in meiner Version 5.0.4.2 von SUSE nur die Funktion des Versteckens, aber nicht des Löschens und Unwirksam-Machens, sondern man muss das Programm austricksen, indem man z.B. das in meinem Fall unerwünschte Aendern von "heiss" nach "heiß" (und einigen ähnlichen, die ich noch gefunden habe) auf die Pseudo-Aenderung von "heiss" nach "heiss" umschreibt. Das scheint in diesem Fall die einzige Lösung zu sein.

Ich habe noch nicht getestet, ob nur Wörterpaare mit Sonderzeichen wie ß oder alle Wörterpaare trotz "Löschen"-Taste nicht löschbar sind.

Beschrieb der Lösung siehe: http://nabble.documentfoundation.org/Er ... 83130.html

Grüsse

bergler

Phoebo
Beiträge: 2
Registriert: Fr 11. Aug 2017, 08:20

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von Phoebo » Fr 11. Aug 2017, 14:41

Hallo

Ich weiss: Dieser Thread ist schon älter, aber ich bin wegen genau diesem Problem hier gelandet. Bei mir betrifft es neben «heiss» auch die doch einiges wichtigeren Worte «Gruss» und «Grüsse». Bin neu auf LibreOffice umgestiegen und ansonsten seeehr zufrieden, aber das ist doch ein sehr anstrengender Bug, wenn man auf die Schweizer Rechtschreibung angewiesen ist und dann bei jeder Grussformel manuell korrigieren muss … :( Und zumindest von aussen scheint es, als ob dieser Bug sich für die Programmierer einfach korrigieren lassen würde. Dafür besteht der Bug doch schon recht lange …

@bergler: Danke für den Link. Dort habe ich eine für mich (Win8.1, LO 5.3.4.2) funktionierende Lösung gefunden. Ich schreibe sie hier kurz rein, damit es anderen vielleicht erspart, sich durch jenen nicht besonders übersichtlichen Thread wühlen zu müssen.

Extras>AutoKorrektur>AutoKorrekur-Optionen>Ersetzungen. (Bei mir war diese Liste noch völlig leer.) Ich habe dort drei neue Einträge gemacht
Gruss -> Gruss
Grüsse -> Grüsse
heiss -> heiss

Seit dem läuft’s wunderbar. (Es bleibt nur der bittere Nachgeschmack, dass so ein komischer Workaround nötig ist, aber der wird mit der Zeit schon vergehen … ;) )

nikki
Beiträge: 218
Registriert: Sa 18. Mär 2017, 22:25
Kontaktdaten:

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von nikki » Sa 12. Aug 2017, 10:14

Hallo,

es ist unsinnig in einem Anwenderforum (Siehe Impressum) Bugs an einer Software zu reklamieren, anstatt sich an die Entwickler zu wenden.
Gruß

----------------------------------------------------------------------------------------------------
Win.10 Prof. 64-bit, LO 5.4.4 (x64), LO 5.3.7 Portable, LO 5.2.7 Portable, AOO 4.1.4

Phoebo
Beiträge: 2
Registriert: Fr 11. Aug 2017, 08:20

Re: Rechtschreibung: Fehler beim Wort "heiß / heiss"

Beitrag von Phoebo » Sa 12. Aug 2017, 11:25

Nur die Ruhe, Nikki. Die eine oder andere Unmutsbezeugung wird schon erlaubt sein. ;) Im Zentrum meines Posts steht ja zudem vielmehr die Lösung, die bei mir funktioniert hat. Da konnte ich zum Glück auf den Link von Bergler bauen. Dort wird allerdings ziemlich hin und her diskutiert und gestritten, so dass man eine Weile liest, bis man rausfindet, was man denn nun wirklich ausprobieren sollte. Falls noch jemand hier landet, weil ihn dieser Bug stört, wollte ich dazu beitragen, dass der die Lösung etwas schneller findet. Nur dazu habe ich mich sogar extra in diesem Forum registriert. Ich vermute mal, dass Dich dieser Bug nicht betrifft, und so hat mein Post bei Dir Unmut anstatt Zeitersparnis ausgelöst, was natürlich nicht meine Absicht war … Sorry.
Ganz entspannte Grüßsse ;)
Phoebo



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast