❤ Unterstütze jetzt das LIBREOFFICE-Forum ❤

Bildabstände unterschiedlich

WRITER hat alles, was Sie von einer modernen, voll ausgestatteten Textverarbeitung erwarten.
Antworten
Lastknightnik
Beiträge: 4
Registriert: Mo 21. Okt 2019, 17:14

Bildabstände unterschiedlich

Beitrag von Lastknightnik » Di 30. Jun 2020, 16:52

Hallo zusammen,

ich habe da ein Problem, das mir wirklich Rätsel aufgibt. Innerhalb eines Dokumentes kommt es beim Einfügen von Grafiken zu unterschiedlichen Abständen. So sieht das auf zwei Seiten aus:
Formatierungsfehler Bilder.png
Formatierungsfehler Bilder.png (264.17 KiB) 1957 mal betrachtet
Das Interessante ist: Die Bilder sind gleich groß, vom gleichen Typ, immer am Absatz aufgehängt. Es gelten dieselben Absatzregeln im Text (einzeilig, zentriert, Größe 8), die Seiten sind gleich (Standardvorlage) und auch die Grafiken selbst haben die gleichen Einstellungen. Also keinen Rahmen, keine zusätzlichen Abstände etc. Beim Wechsel der Seite fing er plötzlich damit an. Ich hab gefühlt schon hundert Stellschrauben ausprobiert, aber den Grund noch nicht gefunden. Habt ihr da vielleicht eine Idee?

Dake schon einmal im Voraus,
Nik

craig
Beiträge: 636
Registriert: Do 21. Apr 2016, 11:42

Re: Bildabstände unterschiedlich

Beitrag von craig » Di 30. Jun 2020, 21:37

Hallo Nik,

wenn es nur Bilder sind, dann würde ich mit LibreOffice-Draw arbeiten:
LibreOffice Draw Bilder.odg
(28.53 KiB) 17-mal heruntergeladen
Oder ein Umweg über Draw:
  1. Füge alle gewünschten BIlder einer Seite in eine Folie ein und positioniere die Bilder.
  2. Gruppiere die Bilder.
  3. Schneide die Gruppierung aus und füge sie dann in Writer ein.
  4. Verankere das große Bild an der Seite.
  5. Im Kontextmenü befindet sich nun die Option "Position und Größe",
    welche wie in Draw einstellbar ist.
Gruß

Craig

Nie die Sicherungskopie vergessen!

════════════════════════════════════════════════
WIN 10 Pro 64-Bit • LO 6.4.4.2 (x64) • AOO 4.1.6

Benutzeravatar
miesepeter
Beiträge: 1155
Registriert: So 19. Dez 2010, 18:16
Wohnort: Bayern

Re: Bildabstände unterschiedlich

Beitrag von miesepeter » Mi 1. Jul 2020, 06:52

Es wäre auch möglich, die Bilder "als Zeichen" in Tabellen zu verankern? Habe damit oft gute Erfahrungen gemacht... - Ciao

Lastknightnik
Beiträge: 4
Registriert: Mo 21. Okt 2019, 17:14

Re: Bildabstände unterschiedlich

Beitrag von Lastknightnik » Do 2. Jul 2020, 08:36

Hallo,

@craig: danke für den Hinweis. Damit habe ich es hingekriegt, das löst zwar das Symptom, aber ich wäre auch an der Ursache interessiert. Probehalber habe ich es mit einer anderen Libre-Installation (gleiche Version, anderer Rechner) aufgemacht und siehe! - da waren die Abstände wieder normal. Jetzt verstehe ich offiziell nurmehr Bahnhof... Also bin ich die EInstellungen durchgegangen bzgl. LO generell, dann das Dokument, dann die Seite... alles identisch.
Wichtig: DIe bereits vorhandenen zu großen Abstände sind nicht heilbar, aber wenn ich einen manuellen Seitenwechsel einbaue, dann ist auf der neuen Seite wieder alles normal.
Bin leidlich verwirrt. Ich glaub, ich bau das Dokument dann doch mal in Tex, da passieren weniger so Zufälligkeiten. Dennoch danke für den Tipp - bei einem kleinen Dokument würde ich es auch machen, aber das ist ein Jahrbuch mit rund 150 Seiten, da ist mir das zu aufwändig...

@miesepeter: Das hatte ich schon probiert. Beim Aufhängen am Zeichen bleibt der Effekt derselbe, wenn ich es als Zeichen einfüge, dann verschwindet - logischerweise - etwa 95% der Grafik, weil nurmehr die Zeilengröße sichtbar bleibt. Das lässt sich mit entsprechend großer Schriftgröße zwar beheben.... aber dann werden die Abstände auch gigantomanisch. Eine Verankerung an der Seite schubst zwar alles ein bisschen durcheinander, lässt aber an der irgendwo eingbebauten Abstandsregel auch nichts ändern. Es ist mir wirklich ein Rätsel.

Einen Verdachtsfall hatte ich noch: DIe Schriftart. Das rückt die Bilder minimal zusammen. Da aber bei beiden gezeigten Seiten die gleiche Absatzvorlage, mithin auch die gleiche Schriftart vorliegt, kann das nicht den Unterschied ausmachen. Ein anderer Verdacht war die Vorlagenformatierung: Nach der Überschrift 2, die ich hier als Zwischenüberschrift nutze, ist eigentlich "Textkörper" als Folgevorlage eingestellt. Aber den Textbereich, den ich nutze, ist Standard. Das ist manuell "drübergelegt". Ob es daran liegen könnte..? Jedenfalls habe ich die Überschriftenvorlage mal geändert, aber das hat nichts getan. Kann es evtl. auch nicht, weil die Texte und Grafiken ja nun schon stehen...

Dennoch vielen lieben Dank für Eure Antworten! :)

Hazel
Beiträge: 482
Registriert: Mi 22. Mai 2013, 10:34
Wohnort: Heroldsberg (ERH)

Re: Bildabstände unterschiedlich

Beitrag von Hazel » Do 2. Jul 2020, 11:00

Hallo Lastknightnik

Ich arbeite seit Jahren nach miesepeters Vorschlag und bin damit immer gut gefahren.

Trotzdem noch ein Wort zur Ursachenforschung:
Probehalber habe ich es mit einer anderen Libre-Installation (gleiche Version, anderer Rechner) aufgemacht und siehe! - da waren die Abstände wieder normal.
Also dieselbe Datei geöffnet mit einer frischen LO-Installation - richtig? Falls ja, dann richtet sich der Verdacht nun eher auf irgendwelche bizarren Konfigurationseinstellungen des LO selbst. Falls dort irgendwelche "unsichtbaren" Überreste früherer Anpassungen schlummern, die heute aus dem Ruder laufen, dann könntest du durch 1. LO herunterfahren, 2. Pfad zu den Konfigurationsdateien umbenennen, 3. LO-Neustart das Problem evtl. loswerden.

Ist ja nur ein Tipp... wie gesagt, damit auch mal der kriminalistische Spürsinn zu seinem Recht kommt.

Grüße
Hazel

PS: TeX ist immer eine gute Idee.
LibreOffice 6.3.6.2, openSUSE Leap 15.1

Antworten