Ich habe ein großes sverweis Problem :-(

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
timtalermd
Beiträge: 1
Registriert: Fr 14. Feb 2020, 10:57

Ich habe ein großes sverweis Problem :-(

Beitrag von timtalermd » Fr 14. Feb 2020, 11:24

Hallo,

ich habe ein Problem und leider noch keine Lösung gefunden. Mein Lieferant hat eine Liste mit EAN Nummern, diese kann ich in eine Software eingeben und diese gibt mir eine Liste mit Daten aus, hier hat jedoch die Liste für ein und dasselbe Produkt bis zu 9 EAN (ich vermute mal, es hat was mit der Haltbarkeit zu tun). Wie finde, ich nun die richtige EAN Nummer raus die mein Lieferant hat?

Sverweis nimmt ja nur die erste spalte, es sind aber nun 17 spalten.

=SVERWEIS(A2;$'- Tabellenblatt6'.$A$1:$R$26;18)

Vielleicht hat jemand ein Tip oder Bsp. die Datei hab ich angehängt, danke schon mal.
Dateianhänge
- sverweis.ods
(82.47 KiB) 13-mal heruntergeladen

HeritzP
Beiträge: 506
Registriert: Mo 9. Dez 2013, 19:08

Re: Ich habe ein großes sverweis Problem :-(

Beitrag von HeritzP » Fr 14. Feb 2020, 13:33

Hallo,

mit ein paar Hilfsspalten.
- sverweis_1.ods
(580 KiB) 15-mal heruntergeladen
Gruß HeritzP

mikele
Beiträge: 991
Registriert: Mo 1. Aug 2011, 20:51

Re: Ich habe ein großes sverweis Problem :-(

Beitrag von mikele » Fr 14. Feb 2020, 13:42

Hallo,
wenn die EAN eindeutig sind, sollte dir folgendes Konstrukt helfen:

Code: Alles auswählen

=WENN(UND(SUMMENPRODUKT('- Tabellenblatt6'.$A$2:$Q$26=A2);A2<>"");INDEX('- Tabellenblatt6'.$R$1:$R$26;(SUMMENPRODUKT('- Tabellenblatt6'.$A$2:$Q$26=A2)*(ZEILE('- Tabellenblatt6'.$A$2:$Q$26))));"")
Gruß,
mikele

Antworten